Programming C, C++, Java, PHP, Ruby, Turing, VB
Computer Science Canada 
Programming C, C++, Java, PHP, Ruby, Turing, VB  

Username:   Password: 
 RegisterRegister   
 How to change the error message on apache?
Index -> Off Topic
View previous topic Printable versionDownload TopicSubscribe to this topicPrivate MessagesRefresh page View next topic
Author Message
Amailer




PostPosted: Sat Jul 19, 2003 9:28 pm   Post subject: How to change the error message on apache?

Ok, i wanna change the 404 and etc on my apache server.

I know the .htaccess and etc.

ErrorDocument 404 ....

But that does not work.

Is it something to do with the:

Alias /error/ "C:/Program Files/Apache Group/Apache2/htdocs/error/"


Alias /error/ "@exp_errordir@/"

<Directory "@exp_errordir@/">
AllowOverride None
Options IncludesNoExec
AddOutputFilter Includes html
AddHandler type-map var
Order allow,deny
Allow from all
LanguagePriority en de es fr it nl sv
ForceLanguag
</Directory>

or what? any help?
Sponsor
Sponsor
Sponsor
sponsor
UBC_Wiskatos




PostPosted: Sat Jul 19, 2003 11:59 pm   Post subject: Re: How to change the error message on apache?

Amailer wrote:
Ok, i wanna change the 404 and etc on my apache server.

I know the .htaccess and etc.

ErrorDocument 404 ....

But that does not work.

Is it something to do with the:

Alias /error/ "C:/Program Files/Apache Group/Apache2/htdocs/error/"


Alias /error/ "@exp_errordir@/"

<Directory "@exp_errordir@/">
AllowOverride None
Options IncludesNoExec
AddOutputFilter Includes html
AddHandler type-map var
Order allow,deny
Allow from all
LanguagePriority en de es fr it nl sv
ForceLanguag
</Directory>

or what? any help?


This is what the .htaccess file looks like for my site:

ErrorDocument 400 /errors/404.shtml
ErrorDocument 401 /errors/401.shtml
ErrorDocument 403 /errors/403.shtml
ErrorDocument 404 /errors/404.shtml
ErrorDocument 500 /errors/500.shtml

You put it in the top-most folder you want to apply it to, as it trickles down to all the folders below it in the hierarchy.
Amailer




PostPosted: Sun Jul 20, 2003 12:30 am   Post subject: (No subject)

Ya ya i know all that,
but it don't work. I think its got somethign to do witht he httppd
Tony




PostPosted: Sun Jul 20, 2003 12:43 am   Post subject: (No subject)

cant you just replace those error files?
Latest from compsci.ca/blog: Tony's programming blog. DWITE - a programming contest.
Blade




PostPosted: Sun Jul 20, 2003 1:51 am   Post subject: (No subject)

yeah... if your .htaccess file isnt working you may have your permissions set wrong in your httpd.conf file...

theres a section in there that looks like
Quote:
<Directory "C:/path/to/files">
AllowOverride None
Order allow,deny
Allow from All
</Directory>


you'll have to change it to

Quote:
<Directory "C:/path/to/files">
AllowOverride All
Order allow,deny
Allow from all
</Directory>


so that you can change stuff with your .htaccess file
UBC_Wiskatos




PostPosted: Sun Jul 20, 2003 2:13 pm   Post subject: (No subject)

Blade wrote:
yeah... if your .htaccess file isnt working you may have your permissions set wrong in your httpd.conf file...

theres a section in there that looks like
Quote:
<Directory "C:/path/to/files">
AllowOverride None
Order allow,deny
Allow from all
</Directory>


you'll have to change it to

Quote:
<Directory "C:/path/to/files">
AllowOverride all
Order allow,deny
Allow from all
</Directory>


so that you can change stuff with your .htaccess file


Yeah, I'm not sure how that goes in Windows, because I work with Linux and the CHMOD you set is 666 I believe.
Blade




PostPosted: Sun Jul 20, 2003 4:21 pm   Post subject: (No subject)

you cant chmod in windows... you just ahve to set the override in the httpd.conf file for your .htaccess files to work properly
Amailer




PostPosted: Sun Jul 20, 2003 5:21 pm   Post subject: (No subject)

Blade wrote:
yeah... if your .htaccess file isnt working you may have your permissions set wrong in your httpd.conf file...

theres a section in there that looks like
Quote:
<Directory "C:/path/to/files">
AllowOverride None
Order allow,deny
Allow from All
</Directory>


you'll have to change it to

Quote:
<Directory "C:/path/to/files">
AllowOverride All
Order allow,deny
Allow from all
</Directory>


so that you can change stuff with your .htaccess file



i did not find anything like that....
code:

 <Directory "@exp_errordir@/">
AllowOverride None
Options IncludesNoExec
AddOutputFilter Includes html
AddHandler type-map var
Order allow,deny
Allow from all
LanguagePriority en de es fr it nl sv
ForceLanguag
</Directory>


is all i found
Blade




PostPosted: Sun Jul 20, 2003 7:41 pm   Post subject: (No subject)

well you could try changing the 'Override None' theere to 'Override All'. Restart your server, then see if your .htaccess files work
UBC_Wiskatos




PostPosted: Mon Jul 21, 2003 6:27 pm   Post subject: (No subject)

Blade wrote:
you cant chmod in windows... you just ahve to set the override in the httpd.conf file for your .htaccess files to work properly


I know you can't CHMOD in Windows, but if he is running NTFS, he can set file permissions (that is, the equivalent of CHMOD).
Amailer




PostPosted: Mon Jul 21, 2003 8:01 pm   Post subject: (No subject)

ya ya ya,
Permissions everyone/user what ever
is like CHOMD...for windows though :/

But the prob is still not solved!
Display posts from previous:   
   Index -> Off Topic
View previous topic Tell A FriendPrintable versionDownload TopicSubscribe to this topicPrivate MessagesRefresh page View next topic

Page 1 of 1  [ 11 Posts ]
Jump to:   


Style:  
Search: